web analytics

Mint 19 – eID 2018 installeren in Firefox

Print Friendly, PDF & Email

Om je eID aan de praat te krijgen onder Mint 19, moet een iets andere manier gebruikt worden, dan bij de vorige versies van Linux Mint.

  • Distributie: Linux Mint 19 / Cinnamon
  • Browser : Firefox 61.0.1 (64-bits)
  • eID-lezer: type ACR38U

Volg onderstaande werkwijze om je eID-lezer aan de praat te krijgen.

Wordt de eID-kaartlezer herkend?

Maak gebruik van het commando lsusb in een terminal om te zien of je kaartlezer herkend wordt

Middleware downloaden

Download de laatste Middleware van de officiële eid-website https://eid.belgium.be

Normaal zal de Linux download pagina automatisch aangeboden worden. Kies daar om de .deb-versie te downloaden.

Klik in het aangeboden pop-up schermpje op ‘Accepteren en Downloaden’

Middleware installeren

Installeer het gedownloade  .deb-bestand dat zich in je download folder zal bevinden.

Dubbelklik erop en installeer het.

 

Het .deb-bestand voegt extra repo’s toe aan je systeem. In die repo’s bevinden zich twee programma’s die je moet installeren:

  • eid-viewer
  • eid-mw

eid-software installeren

Open een terminal en tik onderstaande opdrachten in:

sudo apt update

sudo apt install eid-viewer eid-mw

Kaartlezer driver installeren

Hier verschilt de installatie met de vorige versies van Linux Mint.

Wanneer je die stap probeert uit te voeren via het commando

sudo apt install libacru38u

krijg je de melding dat het pakket niet geïnstalleerd kan worden wegens ‘te oud’ of ‘ergens ander te downloaden’, …

Kortom, Linux Mint 19 (of Ubuntu?)  heeft die driver uit hun repositories geschrapt.

Oplossing: We gaan de drivers van een vorige Ubuntu versie gebruiken.

Je kan de driver libacr38u_1.7.11-1_amd64.deb hieronder downloaden.

Indien de download niet lukt, kan je die op https://packages.ubuntu.com/xenial/amd64/libacr38u/download halen.

Driver installeren

De gedownloade driver bevindt zich normaal in je Downloads folder. Dubbelklik er op om de installatie te starten.

Na de installatie van de driver, kan je aan de rit met je eID-kaartlezer.

Via het programma ‘eID Kaartlezer‘ dat je onder het menu ‘Hulpmiddelen‘ vindt, kan je controleren of je eID ingelezen wordt.

eID gebruik onder Firefox

Download de eID add-on voor Firefox via https://addons.mozilla.org/nl/firefox/addon/belgium-eid/

Zodra de add-on geïnstalleerd is, kan je de eID gebruiken onder Firefox.

 

Spread the word. Share this post!

12 Comments

  1. Maurice

    Beantwoorden

    Prima en bruikbare beschrijving Alain.

    Nog een vraag:
    moeten de certificaten:
    Belgium Root CA4 én Citizen CA (– in vertrouwen bewerken –) in FF nog aangevinkt worden ?

    Mvg.,
    Maurice.

  2. Maurice

    Beantwoorden

    Alain, ik heb het vandaag ook eens geïnstalleerd in LinuxMint 19.
    Ik stel vast, dat het niet nodig is om de driver voor de kaartlezer te installeren.
    Het lukt zonder installatie van de driver voor de ‘viewer’.
    Op het forum van LM vond ik het volgende:
    “Installeer het pakket “eID-archive”, zodat de eID-pakketrepositories beschikbaar worden.
    Installeer de “eid-viewer” en/of “eid-mw” pakketten via de normale weg voor uw distributie. Mogelijk moet u hiervoor eerst een update van de indexen doorvoeren, bijvoorbeeld. via “sudo apt-get update”.
    De eID-mw als add-on voor FF moet wel toegevoegd zijn.
    In eerste instantie wilde mijn ID-kaart niet uitgelezen te worden, na het terugnemen en weer instoppen lukte dit wél.
    In FF moet je de certificaten vertrouwen en er moeten maar twee vinkjes geplaatst worden.
    Het aanmelden bij bv.. Mypension.be , verliep vlekkeloos.

    • Willem Hulscher

      Beantwoorden

      Ik heb alles moeten doen zoals bovenstaand. Dus het gaat niet in het algemeen op wat je zegt. Misschien is het omdat de laptop oud is. Ik weet het niet. Het werkt wel nu.

  3. Benny Aendenhof

    Beantwoorden

    Ik heb een clean install LM 19.1 uitgevoerd en ik krijg het momenteel niet aan de praat na het correct opvolgen van u info. Bij mijn vorige versie LM 17.3 lukte dit feilloos.
    Het probleem doet zich voor wanneer ik de software voor de eid-viewer wil installeren. Dit krijg ik in de terminal :

    benny@Benny-LM19:~$ sudo apt update
    [sudo] wachtwoord voor benny:
    Geraakt:1 http://archive.canonical.com/ubuntu bionic InRelease
    Ophalen:2 http://security.ubuntu.com/ubuntu bionic-security InRelease [83,2 kB]
    Geraakt:3 http://archive.ubuntu.com/ubuntu bionic InRelease
    Genegeerd:4 http://dl.google.com/linux/chrome/deb stable InRelease
    Ophalen:5 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]
    Geraakt:6 http://files2.eid.belgium.be/debian sarah InRelease
    Geraakt:7 http://dl.google.com/linux/chrome/deb stable Release
    Geraakt:8 http://repository.spotify.com stable InRelease
    Geraakt:9 http://files.eid.belgium.be/debian sarah InRelease
    Ophalen:10 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]
    Genegeerd:12 http://packages.linuxmint.com tessa InRelease
    Geraakt:13 http://packages.linuxmint.com tessa Release
    247 kB opgehaald in 2s (99,9 kB/s)
    Pakketlijsten worden ingelezen… Klaar
    Boom van vereisten wordt opgebouwd
    De statusinformatie wordt gelezen… Klaar
    Alle pakketten zijn up-to-date.
    benny@Benny-LM19:~$ sudo apt install eid-viewer eid-mw
    Pakketlijsten worden ingelezen… Klaar
    Boom van vereisten wordt opgebouwd
    De statusinformatie wordt gelezen… Klaar
    Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen
    dat u om een onmogelijke situatie gevraagd heeft, of, indien u
    de distributie ‘unstable’ gebruikt, dat sommige benodigde pakketten nog gemaakt moeten worden of uit ‘Incoming’ verwijderd werden.
    De volgende informatie kan misschien helpen de situatie op te lossen:

    De volgende pakketten hebben niet-voldane vereisten:
    eid-viewer : Vereisten: libcurl3 (>= 7.16.2) maar het zal niet geïnstalleerd worden
    E: Kan problemen niet verhelpen, u houdt defecte pakketten vast.
    benny@Benny-LM19:~$

    • Beantwoorden

      Ik maak ondertussen geen gebruik meer van EID, dus kan ik niet direct het probleem aanduiden. Indien je een smartphone hebt kan je beter de ‘ItsMe’ app gebruiken voor toegang tot beveiligde websites. (https://www.itsme.be/)

      Als je toch libcurl3 wenst te installeren, dan zal libcurl4 wel verwijderd worden!!!

      alain@Tecra:~$ sudo apt install libcurl3
      Pakketlijsten worden ingelezen... Klaar
      Boom van vereisten wordt opgebouwd
      De statusinformatie wordt gelezen... Klaar
      De volgende pakketten zullen VERWIJDERD worden:
      curl libcurl4
      De volgende NIEUWE pakketten zullen geïnstalleerd worden:
      libcurl3
      0 opgewaardeerd, 1 nieuw geïnstalleerd, 2 te verwijderen en 0 niet opgewaardeerd.
      Er moeten 214 kB aan archieven opgehaald worden.
      Na deze bewerking zal er 392 kB schijfruimte vrijkomen.
      Wilt u doorgaan? [J/n]

  4. Beantwoorden

    Van Linux Mint 17.3 geüpgrade naar 19.1, en het was even zoeken naar het “hoe”, maar dankzij de uitleg hier is de installatie van de eID-software perfect gegaan.

Geef een reactie

Deze website gebruikt Akismet om spam te verminderen. Bekijk hoe je reactie-gegevens worden verwerkt.

%d bloggers liken dit: