web analytics

eID 2017

Print Friendly, PDF & Email
De inhoud van dit bericht is meer dan een jaar oud. Hou daar rekening mee.

Twee jaar geleden heb ik de werkwijze om je eID-lezer onder Linux aan de praat te krijgen besproken – https://baudrez.be/eid-installeren-onder-linux/.
Ondertussen is die informatie achterhaald en hieronder vind je de meest recente manier om je eID-lezer te installeren.

Werkwijze

Je moet twee zaken doen:

  1. Middleware installeren
  2. Software installeren vanuit de nieuwe softwarebron

Middleware installeren

Ga naar https://eid.belgium.be/nl/hoe-installeer-ik-de-eid-software

Klik op de link onder de knop [Gratis download]

In het popup venster kies je voor [Download voor Linux]

In het nieuwe venster kies je de download voor de distro waar je mee werkt. Voor Ubuntu/Mint is dat een .deb bestand

Accepteer de software licentie en het bestand  eid-archive_2017.4_all.deb wordt gedownload. (Als je op de knop tikt heb je altijd de meest recente versie)

Dubbelklik op het bestand dat normaal in je ~/Downloads map terug te vinden zal zijn en installeer de software. Deze software voegt een repository toe aan je systeem.

Open een terminal en update je systeem om de eID repository in te lezen.

$ sudo apt update

Installeer “eid-viewer” en “eid-mw”. Dat kan enkel als je hierboven de update hebt uitgevoerd.

$ sudo apt install eid-viewer eid-mw

Installeer de driver voor de kaartlezer

Noteer de driver die je op je kaartlezer kan terugvinden. In mijn geval is de driver ACR38U

Installeer dan de library voor dit type van lezer

$ sudo apt install libacr38u

Testen van de installatie

Alles is nu geïnstalleerd.

  • Plug je kaartlezer in
  • Start het eID-Kaart-Lezer programma (terug te vinden onder je ‘Hulpmiddelen‘ menu)
  • Controleer of je kaartlezer driver terug te vinden. Het is niet zeker dat de ‘automatische’ stand de juiste driver selecteert
  • Plaats je identiteitskaart in de lezer en als je de info van je kaart kan zien is alles goed geïnstalleerd

Add-ons installeren

Het is niet omdat je via de eid-kaart-lezer je identiteitskaart kan inlezen dat je zomaar kan inloggen op de Belgische websites zoals Tax-On-Web of MyPension. Je moet een extra add-on installeren.

Firefox

Onder Firefox kan je via https://addons.mozilla.org/nl/firefox/addon/belgium-eid/ de gepaste add-on installeren

Dan pas kan je inloggen op de eID-websites van de Belgische regering.

Chome / Chomium

Het is me tot nu toe nog niet gelukt om via Chrome/Chromium toegang te verkrijgen tot eID-websites

 

Spread the word. Share this post!

17 Comments

  1. Geert Anthonis

    Beantwoorden

    Net als 5 maanden terug loopt het al fout bij ‘sudo apt install eid-viewer eid-mw’. Ik krijg “E: Kan pakket eid-viewer niet vinden”. Het ganse systeem is waardeloos.

  2. Beantwoorden

    eid-viewer en eid-mv zal je nooit vinden als je eid-archive_2017.4_all.deb niet installeert. Beide pakketten bevinden zich enkel in de repo die door eid-archive_2017.4_all.deb geïnstalleerd wordt.

  3. Geert Anthonis

    Beantwoorden

    Heb het deze morgen nog eens geprobeerd. Deze keer van source. Ik denk dat ik weet waar het probleem zit. Als ik ./configure run krijg ik een foutmelding, namelijk: “configure error: Package requirements (libpcsclite >= 1.4.4) were not met:
    No package ‘libpcsclite’ found”. Dat is raar want er bestaat geen libpcsclite package wel een libpcsclite1 package en in mijn Mint 18.1 dat package heeft versie 1.8.14 (The purpose of PC/SC Lite is to provide a Windows(R) SCard interface in a very small form factor for communicating to smartcards and readers.).
    Dus als ik via Gdebi het eid-archive…deb installeer (en ja dat had ik gedaan), dan ‘sudo apt update’ uitvoer en dan ‘sudo apt install eid-viewer eid-mw’ uitvoer krijg ik “E: Kan pakket eid-viewer niet vinden”. En als ik het via scource probeer krijg ik een andere fout die volgens mij geen steek houdt want het bestand dat niet gevonden wordt bestaat niet als beschreven en een versie die zou moeten werken is al geïnstalleerd.
    Mijn broer heeft vier computers en tablets thuis (windows en Andriod) en hij kan enkel op de Andriod tablet het eid systeem gebruiken,

  4. Kris

    Beantwoorden

    Hartelijk dank voor deze info. Na enkele uren hopeloos zelf te hebben gezocht hoe het moest kwam ik terecht op uw pagina. Het enige dat ontbrak was de lezerdriver, die na het intikken van het commando “sudo apt install libacr38u eindelijk werkte! Waarom verschijnt dit niet standaard op de website van EID? mvg Kris

  5. Beantwoorden

    Ik werk met Ubuntu 16.04 en heb het volgende moeten doen om de eid in chrome werkende te krijgen:
    – Sluit chrome als het open staat.
    – Open een terminal en enter volgende commandos (Voer ze na elkaar uit)
    – sudo apt-get install libnss3-tools
    – modutil -dbdir sql:.pki/nssdb/ -add “Belgium eID” -libfile /usr/lib/x86_64-linux-gnu/libbeidpkcs11.so
    DIt is het command om de libnss aan de praat te krijgen.
    Oorspronkelijk verwijst “-libfile’ naar “/usr/lib/libbeidpkcs11.so”
    Wanneer ik het command zo uitvoerde kreeg ik altijd een foutmelding.
    Kijk of libbeidpkcs11 op uw systeem staat.
    Start Synaptic Package Manager
    Typ in het zoek venster: libbeid
    Als libbeidpkcs op uw systeem staat toont Synaptic deze als:
    libbeidpkcs11-bin
    libbeidpkcs11-o
    Stel synaptic geeft aan dat libbeidpkcs11 geinstalleer is, zoek dan op waar de dingen staan.
    Open nautillus, browse naar /usr en typ daar als search function: libbeid
    Een aantal mogelijkheden poppen up.
    pick er libbeidpkcs11.so uit en right click – properties.
    onder location vind je het path waar de file staat.
    Enter dat path na “-libfile” (bij mij was dat dus: /usr/lib/x86_64-linux-gnu/libbeidpkcs11.so}
    – Als alles goed gaat krijg je nu de melding: Module “Belgium eID” added to database.
    – Test de installatie met: modutil -dbdir sql:.pki/nssdb/ -list

    – Start chrome en ga naar de eID web site voor een test.

    Groeten,

    Marc

    • Fred Meijer

      Beantwoorden

      Ik deed het volgende , na alles voor Firefox geïnstalleerd en getest te hebben :

      in terminal

      sudo apt-get install libnss3-tools ( enter)
      cd (enter)
      # modutil -dbdir sql:.pki/nssdb/ -add “Belgium eID” -libfile ‘/usr/lib/i386-linux-gnu/libbeidpkcs11.so.0’ (enter)
      sudo apt update (enter)

      Herstart linux Mint 18.3…cardreader insteken id erin start chrome en website Csam test
      aanmelden.

  6. Gert

    Beantwoorden

    Bedankt voor de gedetailleerde uitleg, maar ik zit toch nog met een probleem.
    Wanneer ik de driver voor de kaartlezer ACR38U-CFC-BLI wil installeren (Ubuntu 17.10), verschijnt onderstaande melding:

    sudo apt install libacr38u
    Pakketlijsten worden ingelezen… Klaar
    Boom van vereisten wordt opgebouwd
    De statusinformatie wordt gelezen… Klaar
    Pakket libacr38u is niet beschikbaar, hoewel er naar verwezen wordt door
    een ander pakket. Mogelijk betekent dit dat het pakket ontbreekt,
    verouderd is, of enkel beschikbaar is van een andere bron

    Voor één of andere reden is het pakket libacr38u niet beschikbaar.
    Heeft er iemand enig idee wat hiervan de oorzaak kan zijn?

    Alvast bedankt.

    • Maurice

      Beantwoorden

      Gert,
      Ubuntu 17.10 wordt niet lang meer ondersteund (nog tot 2018.07). Je zou best de nieuwere versie van Ubuntu (18.04 LTS) installeren — Ubuntu 17.10 is eigenlijk maar een testversie en is géén lang leven beschoren (meestal maar 9 maanden).
      Ik hoop dat deze info verhelderend is.
      Conclusie: het zou best kunnen dat het probleem voor het installeren van eID opgelost is.
      Groet,
      Maurice.

  7. Geert Anthonis

    Beantwoorden

    Als de nood het grootst is is de redding nabij. Het heeft 5 uren gekost en heelwat omwegen die ik zowat overal te samen heb moeten zoeken om er in te slagen om mijn identiteitskaart gelezen te krijgen. Op Firefox werkt het ganse systeem nog altijd niet maar na enkele extra stappen buiten wat hier al vermeld is werkt het voorlopig op Chromium zonder problemen. En dat allemaal om er achter te komen dat ik helemaal geen recht heb op een pensioen….
    ‘t Was dus de moeite waard om het systeem eindelijk eens aan de praat te krijgen.

    Laten we stellen dat op mijn Linux Mint ‘Sarah’ heel wat extra lib…-dev nodig bleken en enkele FLAGS moesten gezet worden en dat dan en enkel dan ik in staat was het eid-mw van source te installeren. Alle andere alternatieven hadden totnutoe gefaald.

  8. Didier

    Beantwoorden

    Hartelijk dank voor de gedetailleerde installatieprocedure. Werkt perfect op Ubuntu 17.10 met Firefox Quantum 59. Wat ik echter niet begrijp is waarom ik de middleware “eid-viewer” en “eid-mw” niet kon zien via de grafische Ubuntu Software ook nadat de ik de nieuwe softwarebron (PPA) toegevoegd had. Geen probleem om dat dan maar via terminal te doen, maar dat zou toch hetzelfde moeten zijn. Gelukkig via Google deze pagina gevonden. Met Mint vroeger nooit een probleem gehad on na de PPA toevoeging grafisch de middelware te vinden. Ik heb trouwens de driver van de kaartlezer niet moeten installeren. Voor mijn confuguratie was het volgende voldoende:
    – eid-archive_2017.4_all.deb (downloaden & installeren via eid website)
    – sudo apt update
    – sudo apt install eid-viewer eid-mw
    – Firefox add on installeren

    Mvg, Didier

  9. Eduard Hontelé

    Beantwoorden

    Mijnheer Baudrez, Bedankt voor deze duidelijke uitleg. Na een hoop gepruts kwam ik op uw website terecht en het kwam direct in orde. Ik gebuik Ubuntu 16.04 LTS en Firefox.
    Vriendelijke groeten,

    Eduard Hontelé

  10. Maurice

    Beantwoorden

    Alain, is de beschreven methode, om de eID software te installeren, ook van toepassing / bruikbaar in de LinuxMint 19 versie?
    Heb je dat al eens getest ?

    Groet,
    Maurice.

    • Beantwoorden

      Maurice,

      ik werk aan een nieuw blogberichtje daar er onder Mint 19 blijkbaar wat addertjes onder het gras gekropen zijn. Zodra ik het bij mij draaiende heb en mijn info gepost hebt, zal je normaal geen problemen hebben om je eID onder Mint 19 aan de praat te krijgen.

Geef een reactie

Deze website gebruikt Akismet om spam te verminderen. Bekijk hoe je reactie-gegevens worden verwerkt.

%d bloggers liken dit: