web analytics

Ubuntu Unity 16.04 niks speciaals

Print Friendly, PDF & Email

Zoals gewoonlijk is de maand april (naast de maand oktober) de maand waarin Canonical nieuwe versies publiceert. Om de twee jaar komt er in april ook een LTS (Long Term Support) versie uit. Op 21 april werd Ubuntu 16.04 officieel gereleased.

ubuntu1604

Systeemvereisten

Ubuntu Unity 1604 begint een zwaargewicht te worden. Je moet toch al gauw op 2 GB RAM rekenen om die een beetje vlot te kunnen draaien, waardoor vele oudere systemen uit de boot vallen.

Unity Desktop

Hier ontgoochelt Ubuntu. Geen Unity 8, maar wel nog altijd de gekende Unity 7.4
Op zich is dat wel logisch, daar Unity 8 de MIR display technologie nodig heeft om te draaien. MIR is de vervanger voor de klassieke X-technologie die je scherm aanstuurt. Tot nu toe werkt Unity 8/MIR enkel met Intel drivers, maar AMD en nVidia zullen ook met MIR-compatible drivers komen in de toekomst.
Wat Canonical wil bereiken is wat ze ‘convergency’ noemen. Dat wil concreet zeggen eenzelfde look-and-feel op alle apparaten die Ubuntu draaien, zoals hieronder uitgebeeld.
unity8-mir

Het enige dat nieuw is in Unity 7.4 op de 16.04 is dat je de Starter die altijd al links op je scherm staat, nu ook onderaan gezet kan worden. Dat is feitelijk een doekje tegen het bloeden, want op alle andere Display Environments (Cinnamon, KDE, XFCE, LXDE, MATE, ….) is het verplaatsen van het paneel op de vier zijden van je display al jaren de normaalste zaak van de wereld. Enkel bij Unity niet. Na vier jaar kan je via onderstaande code de starten onderaan plaatsen, maar dat is het dan ook.

Starter links zetten

$ gsettings set com.canonical.Unity.Launcher launcher-position Left

Starter onderaan zetten

$ gsettings set com.canonical.Unity.Launcher launcher-position Bottom

De aanpassing gebeurt direct.

starter_bottom

Softwarecentrum

Het klassieke softwarecentrum dat we al jaren gebruikten is niet meer. Het is vervangen door Gnome Software dat merkelijk minder geheugen nodig heeft dan zijn voorganger.
New-Ubuntu-Software-Center-16-04

Online zoeken

Tot en met Ubuntu 15.10 was de standaard instelling zo, dat bij een zoekopdracht in de Unity Dash je zoekopdracht automatisch doorgesluisd werd naar externe servers van Canonical die op hun beurt maakten dat je zoekresultaten van Amazon voorgeschoteld kreeg. Nu is het net andersom. Zoekopdrachten blijven beperkt tot je systeem, tenzij je zelf de optie om online te zoeken aanzet.

Apt verdringt apt-get

Als je regelmatig met de terminal werkt, dan ben je vertrouwd met de klassieke apt-get commando’s. Vanaf 16.04 neemt het commando apt de fakkel over. Je kan nog steeds met apt-get werken, maar apt zal in de toekomst de standaard opdracht worden.
Apt is geen nieuw commando, het wordt al jaren door Debian en afgeleide distro’s gebruikt. Zo zal je nu apt install programma gebruiken in plaats van apt-get install programma, of apt update && apt upgrade in plaats van apt-get update && apt-get upgrade, enz…
Het zichtbare verschil tussen apt en apt-get is dat je bij apt een voortgangsbalk zal zien in je terminal.
apt-Ubuntu-16-04

Geen ondersteuning voor AMD/ATI Radeon proprietary drivers

Ubuntu 16.04 laat de ondersteuning voor AMD’s Catalyst Linux driver, gekend als fglrx vallen. Deze proprietary graphics driver zal vervangen worden door AMDGPU, de open source driver ontwikkeld door AMD.

Maar er zijn problemen met de AMDGPU. Ten eerste is het nog in ontwikkelingen dus nog niet af. Ten tweede is de driver niet compatibel met oudere videokaarten.

Kortweg gezegd: Radeon gebruikers, laat Ubuntu 16.04 momenteel links liggen.

Nieuwe en bijgewerkte software

Veel versies zijn bijgewerkt. Hieronder een kort lijstje met enkele updates:

  • Mozilla Thunderbird 45.0
  • LibreOffice 5.1
  • Python 3.5
  • QML-based USB Startup Creator
  • Docker 1.10
  • Linux Kernel 4.4

De meeste van die versies kun je gewoonweg installeren via een gewone update.

Het brandprogramma Brasero en de instant messaging app Empathy zijn verwijderd uit de standaard installatie. De reden is dat beide pakketten al een hele poos door de openbron gemeenschap niet meer ondersteund werden. Je kan die natuurlijke wel nog installeren via het softwarecentrum.

Andere nieuwigheden, meer voor professionals

ZFS ondersteuning

Ubuntu komt nu met ondersteuning voor het ZFS bestandssysteem. De naam betekent Zettabyte File System, maar is nu bekend als een letterwoord. Dit omdat de datalimiet een zettabyte is. Een zettabyte (afgekort ZB) is 1.000.000.000.000.000.000.000 (1021) bytes. Zetta is de SI-prefix voor een triljard. Dat is nu net niet de grootte van opslagcapaciteit voor een modale gebruiker…

Veelvouden van bytes
met SI-voorvoegsel met binair voorvoegsel afwijking
tussen SI
en binair
symbool naam voor-
voegsel
waarde symbool naam voor-
voegsel
waarde
kB kilobyte kilo 10001 = 103 KiB kibibyte kibi 10241 =210 2,4%
MB megabyte mega 10002 = 106 MiB mebibyte mebi 10242 =220 4,9%
GB gigabyte giga 10003 = 109 GiB gibibyte gibi 10243 =230 7,4%
TB terabyte tera 10004 = 1012 TiB tebibyte tebi 10244 =240 10,0%
PB petabyte peta 10005 = 1015 PiB pebibyte pebi 10245 =250 12,6%
EB exabyte exa 10006 = 1018 EiB exbibyte exbi 10246 =260 15,3%
ZB zettabyte zetta 10007 = 1021 ZiB zebibyte zebi 10247 =270 18,1%
YB yottabyte yotta 10008 = 1024 YiB yobibyte yobi 10248 =280 20,9%

SNAP packaging

Met convergency in het achterhoofd, heeft Canonical gekozen om voor Ubuntu SNAPPY packaging te introduceren. Kort gezegd betekent dit, dat in één bestand, zowel het programma als alle afhankelijkheden voor dat programma zullen zitten. Daarmee wordt komaf gemaakt met ‘niet voldane afhankelijkheden’ bij het installeren van bestanden. Als gebruiker ga je daar niet veel van zien. Of een programma nu via een .deb-bestand of een snappy pakket geïnstalleerd wordt, zal voor ons niks uitmaken.

Besluit

Canonical doet verder met het opleveren van onvolledige distro’s. Als je met de 14.04.4 LTS werkt is er momenteel geen enkele reden om naar de 16.04 te upgraden. Je doet er sowieso altijd best aan om te wachten op de .1-versie, omdat de meeste bugs dan opgelost zullen zijn.

Persoonlijk zal ik Unity, die toch een veelvraat is van geheugen, links laten liggen en Ubuntu MATE 16.04 installeren en uitproberen.
Pas in het geval van de aankoop van een Ubuntu Tablet en/of Ubuntu Smartphone zal ik Unity desktop terug eens onder handen nemen.

327 totaal aantal vertoningen, 2 aantal vertoningen vandaag

Beoordeling

3 Reacties

  1. François

    Als ik de systeemvereisten lees ga ik Ubuntu 16.04 niet kunnen installeren op mijn verouderde test computer . Deze bevat nog een single core processor , terwijl voor Ubuntu 16.04 minstens dual core processor vereist is .

    Reageren
  2. Maurice

    Alain,
    heb er intussen al veel over de nieuwe Ubuntu-release 16.04 gelezen. Vooral op het Ubuntu-forum, de meningen zijn daar nogal uiteenlopend.
    En, het is zoals je schrijft: een zwaargewicht aan het worden. Het is, jammerlijk, bij alle nieuwe distro’s zo.
    Onze “oudjes” gaan het op een bepaald moment niet meer kunnen “trekken”.
    Weer, vroeg of laat, ‘kosten’, de economie moet draaien hé — anders is er werkloosheid — en de consumptie moet op peil worden gehouden … en ga zo maar door.

    Persoonlijk hou ik het bij PCLinuxOS Kde 64-bit op alle computers (5x)( = rolling release ) en dat bevalt mij het best.

    Iedereen is vrij van keuze.

    Jou artikel, Alain, is wel verhelderend en eerlijk geschreven. Een dikke duim omhoog.
    Ik vind dat dit op zijn plaats is als informatie ook al zijn er die een andere distro gebruiken. Met dank.
    Duim omhoog! En …een kus(je) van de juf en een bank vooruit.

    Mvg.,
    Maurice.

    Reageren
  3. fcbrugge

    Zelf val ik nog bij de goede..heb 4GB ram.
    Veel verandering zie ook niet, zo diep als Alain graaf ik niet..is voor experts…ben ik niet!
    Ook gezien dat Gparted niet standaard is…was ervoor wel…weet het niet meer.
    Ook herkent Ubuntu mijn tablet nu…b.v. Zorin nog niet!
    Heb het beetje meer voor systemen van ARCH!

    Reageren

Geef een reactie

%d bloggers liken dit: