web analytics

eID installeren onder Linux

Print Friendly, PDF & Email

Dit artikel is vervangen door de versie 2017: eid 2017

Hoe te werk gaan om de eID-lezer te gebruiken onder Linux

De Belgische overheid heeft een speciale website voor de eID. http://eid.belgium.be/nl/

Daar vind je veel informatie over het hoe en wat van je eID, maar waar wij het meest in geïnteresseerd zijn, is de pagina die handelt over de installatie en gebruik van je eID-lezer onder Linux.

De pagina: http://eid.belgium.be/nl/je_eid_gebruiken/de_eid-middleware_installeren/linux/

Het installeren van de eID-software voor Linux omvat twee stappen:

  1. Installeer het “eID-archive” pakket, zodat de eID-pakketrepositories beschikbaar worden.
  2. Installeer de “eid-viewer” en/of “eid-mw” pakketten vanuit de repositories.

Installatie eID-archief

Voor Linux Mint 17/17.1/17.2 (en Debian 7 “Wheezy”, Ubuntu 12.04 LTS “Precise Pangolin”, Ubuntu 14.04 LTS “Trusty Tahr”, Ubuntu 14.10 “Utopic Unicorn”, Linux Mint 13 “Maya”) download je het bestand eid-archive.deb (DEB, 5.9 Kb) :
http://eid.belgium.be/nl/binaries/eid-archive_2015%2E1_all_tcm227-259783.deb

Opmerking: Dit is de rechtstreekse link naar de middleware software. Indien er een fout optreedt (file not found bv.), moet je naar de download pagina gaan en daar de recentere versie binnenhalen.

  • Installeer dat bestand. (Dubbelklikken op het bestand dat in je Downwloads map geplaatst is, of via de terminal met het commando gdebi).
  • Update de indexen via ‘sudo apt-get update’

Installeer de eID-viewer, eID-mw en de driver voor de eID-reader

Dat doe je via het volgende commando:

$ sudo apt-get install eid-mw eid-viewer libacr38u

Opmerking 2016/06/02: libacr38 hernoemd tot libacr38u. Mocht libacr38u niet werken kan je altijd met libacr38 proberen.

Welke versie van middleware heb je zopas geïnstalleerd?

De versie van de middleware die je draait, kun je terugvinden via het commando about-eid-mw.

$ about-eid-mw

about-eid-mw_036

Controle van de werking van je kaartlezer via het pakket eID-viewer.

  1. Sluit je eID-lezer aan
  2. Open de eID-viewer software
  3. Plaats je eID in de lezer

Als alles correct is verlopen moet je de inhoud van je eID kunnen zien

eID Viewer_035

Voeg de eID add-on toe bij Firefox

Daarmee is de kous echter nog niet af. Lokaal werkt alles nu wel, maar als ik op een website mijn eID wil gebruiken moet ik mijn browser nog aanpassen. Om via Firefox op zo’n website te kunnen inloggen, is er een specifieke add-on ontwikkeld.

Die kun je vinden door te zoeken naar eid in de Firefox store: https://addons.mozilla.org/nl/firefox/

Vanaf nu mag je gerust reeds je e-card reader met je eID er in aan je PC koppelen.

Selectie_037
Installeer de add-on

Programmatuurinstallatie_038

Herstart Firefox.

Je vind de werkende add-on terug tussen de geïnstalleerde add-ons in Firefox

Selectie_040

The proof of the pudding…

Als je nu naar een website surft waar je via je eID kan inloggen, zou alles vlot moeten verlopen.

De website my.belgium.be bevat een hele pagina vol met (overheids)diensten. Diensten waar je via de eID moet inloggen zijn te herkennen aan het eID icoontje naast hun naam.

Selectie_044

Klik op de blauwe knop Inloggen en je wordt doorverwezen naar CSAM-pagina

Aanmelden via CSAM

Om toegang te krijgen tot een online dienst van de overheid, moet je je eerst aanmelden via CSAM. Zo worden je identiteit en je toegangsvoorwaarden gecontroleerd en krijg je op een veilige manier toegang tot de online dienst van je keuze.

Selectie_045

Klik op verdergaan. Je eID wordt ingelezen en het correcte certificaat wordt getoond. Je moet dat certificaat accepteren.

Gebruikersidentificatieverzoek_046

Om zeker te zijn dat jij wel de rechtmatige eigenaar bent van de eID, moet je de pin-code van je eID ingeven. Je doet dat door met de muis te klikken op de cijfers die je code vormen. Ik heb ervaren dat je dat per sessie maar 1 x moet doen blijkbaar.

beID: PIN Code Required_048

Je komt dan terug naar my.belgium.be waar je als ingelogd wordt weergegeven.

Selectie_049

Als dan naar een dienst surft waar het eID-icoontje aantoont dat je je moet aanmelden, moet je in feite enkel het specifieke certificaat voor die dienst accepteren en je logt zo in.

Extra opmerking:

Staf, moderator bij http://linuxmintusers.be meldt het volgende:

  1. libacr38u is alleen nodig voor kaartlezers van dat type, meestal niet nodig.
  2. volgende certificaten moeten bijgewerkt worden in Firefox.
    Firefox – voorkeuren – geavanceerd – certicaten – certificaten bekijken –
    • Belgian root CA3, bij alle drie de drie items aanvinken via vertrouwen bewerken
    • Belgian root CA4, Governemenr CA, drie items aanvinken
    • Cybertrust, Belgian root CA4, drie items aanvinken
    • Firefox herstarten

Edit 20160602: libacr38 hernoemd tot libacr38u

10,276 totaal aantal vertoningen, 4 aantal vertoningen vandaag

Beoordeling

16 Reacties

  1. Robert Monbaliu

    Geachte,

    is bovenstaande procedure ook letterlijk van toepassing voor de distributie Ubuntu Mate?
    Dank bij voorbaat,

    Robert

    PS: ik was heden op het Linux Café aanwezig.

    Reageren
    1. eijie (Auteur bericht)

      Robert,

      het zou niks mogen uitmaken, daar de instellingen niks met je GUI te maken hebben.

      Reageren
  2. Marc

    Beste,

    Lukt me niet op MintMaya Xfce 32bit
    Ik ga het eens proberen op mijn Mint 17.1 Cinnamon 64 bit die als file server staat te draaien.
    Maar het lijkt eerder een driver probleem te zijn voor de Vasco id reader

    Reageren
    1. eijie (Auteur bericht)

      Marc,

      het is inderdaad meestal de driver van de eID-reader die problemen geeft.

      Reageren
  3. koen plessers

    Beste,

    Ik heb dit bestand gebruikt voor installatie: http://eid.belgium.be/sites/default/files/downloads/eid-archive_2015.4_all.deb

    Ik krijg nu de foutmelding: Package ‘eid-viewer’ has no installation candidate

    Met vriendelijke groeten

    Koen

    Reageren
    1. eijie (Auteur bericht)
  4. Maurice Vansteelandt

    Patrick had enorm moeite om het (eid-kaartlezer van Logon = nieuw) op zijn laptop werkend te krijgen, en had mijn hulp ingeroepen–deze namiddag Patrick geholpen en we stelden vast ( er was al het een en ander van de eid geïnstalleerd)
    –de sudo apt-get install libacr38 lukte niet:
    het moest zijn: sudo apt-get install libacr38u.
    De kaartlezer wilde maar niet werken –deze namiddag meermaals geprobeerd en de installatieprocedure meerdere malen opnieuw uitgevoerd.
    De eid-kaartlezer dan aan een andere computer (die van mij = Maurice) aangesloten en die lichte niet op.

    Op een nog andere laptop (van Patricks vrouw) aangesloten –een volledige installatie (1ste keer) doorlopen en alles werkte perfect. Patrick blij natuurlijk.

    De vraag is nu : zouden de usb-poort(en) eventueel –op zijn laptop –roet in het eten gooien of hadden we alles van eid moeten verwijderen en dan een NIEUWE en SCHONE installatie moeten uitvoeren?

    Mvg.,
    Maurice (Mauk)

    Reageren
    1. eijie (Auteur bericht)

      Het verwijderen van oudere versies kan nooit kwaad als je niet zeker bent dat ze allemaal overschreven worden bij een nieuwe install.
      Je kan ook proberen met het commando lsusb om te zien of de kaartlezer herkend wordt.

      Reageren
  5. Jurgen Gaeremyn

    Is het ook mogelijk om de eid te gebruiken als login voor Ubuntu?

    Reageren
    1. eijie (Auteur bericht)

      Jurgen,

      dat denk ik niet. Ik heb wel al mijn fingerprint-reader aan de praat gekregen onder Mint, maar dat werkt jammer genoeg niet bij het inlogscherm, enkel in de GUI om je root-access te valideren, ipv een wachtwoord te tikken.

      Reageren
  6. christiane

    Works also perfectly in Debian 8 (Jessie).
    I didn’t need libacr38 but the root certificates must be installed to get the login at mybelgium.be to work in Firefox. ( I found them at http://repository.eid.belgium.be/certificates.php?cert=Root&lang=en )

    Reageren
  7. christophe

    Thanks for the command who’s finally help me to install EDI successfully with my ubuntu mate desktop!!

    “$ sudo apt-get install eid-mw eid-viewer libacr38u”

    Rgds

    Christophe

    Reageren
  8. Dominique

    Dank u, goed uitgelegd. Ik kreeg mijn kaartlezer niet aan de praat met de uitleg van de FOD. Ik heb deze procedure gevolg en de kaartlezer werkte direct.

    Reageren
    1. Dominique

      vergeten te vermelden Linux Mint 17 Cinnamon 2.2.16

      Reageren
  9. drup

    tophulp!!!! vele malen beter dan wat op de site van de overheid zelf staat! meermaals geprobeerd via hun instructies, maar kan zelfs nog niet eens op de testpagina geraken! uw instructies werken perfect van de eerste keer! ik heb wel na de installatie de pc even herstart 🙂

    Reageren

Geef een reactie

%d bloggers liken dit: