web analytics

eID en Firefox 57… problemen… en oplossing

Print Friendly, PDF & Email

De meesten onder ons zijn ondertussen al via de automatische updates met Firefox 57 Quantum aan het werken.


Zij die met die nieuwe versie hun eID willen gebruiken staan plots voor een onaangename verrassing.

Het ding wil je niet meer inloggen !!!

Blijkbaar is er in Firefox 57 iets veranderd en als je naar de add-on pagina van de eID gaat (https://addons.mozilla.org/nl/firefox/addon/belgium-eid/) lees je daar onder meer het volgende:

We zitten dus opgescheept met een versie van Firefox die met een bug zit, waardoor de eID niet meer naar behoren werkt.

Klik je in dit kadertje op Bug 1357391 dan zie je dat Wouter Verhelst van Fedict deze problematiek al gemeld heeft, maar dat het jammer genoeg voor ons wachten zal zijn tot Firefox het probleem oplost ergens vanaf versie 58. Daar lost ons probleem nu niet op natuurlijk.

Edit: Georges Landschoot meldt het volgende: “Er is een nieuwe update van de add-on eiD België 1.0.26 (versie 30/11/2017). Heb deze geïnstalleerd en dat werkt in Linux mint.

Een mogelijke oplossing

Een mogelijke oplossing is het downgraden of naar een vorige versie van Firefox terugvallen.

Stap 1

Werk je niet via Sync dan doe je er best aan om vanuit Firefox 57 je favorieten naar een HTML-bestand te exporteren.

Stap 2

Verwijder de huidige Firefox van je systeem

$ sudo apt purge firefox*

 

Stap 3:

Downgrade naar Firefox ESR 52 (deze versie zal ondersteund worden  tot 26/06/2018 en zal veiligheidsupdates krijgen).

Je hebt hiertoe twee opties:

  • Haal Firefox ESR 52.5.0 binnen via Jonathon F’s PPA. Je kan deze versie installeren op Ubuntu 14.04 LTS (Trusty Tahr) en 16.04 LTS (Xenial Xerus) en andere distro’s die op deze twee gebaseerd zijn, via volgende commando’s:
    sudo add-apt-repository ppa:jonathonf/firefox-esr
    sudo apt-get update
    sudo apt-get install firefox-esr
    

Ofwel

  • Haal Firefox ESR 52.5.0 binnen via Mozilla Team’s PPA. Je kan deze versie installeren op 14.04 LTS (Trusty Tahr), 16.04 LTS (Xenial Xerus), 17.04 (Zesty Zapus), 17.10 (Artful Aardvark) en 18.04 LTS (Bionic Beaver) via volgende commando’s:
    sudo add-apt-repository ppa:mozillateam/ppa
    sudo apt-get update
    sudo apt-get install firefox-esr
    

Ik heb voor de tweede oplossing gekozen

Op die manier zijn we tijdelijk terug ‘mee’ met onze eID onder Firefox… oef 🙂

1,375 totaal aantal vertoningen, 40 aantal vertoningen vandaag

Beoordeling

7 Reacties

  1. Benny

    Ik heb ook reeds de nieuwe Firefox 57 op mijn pc (LinuxMint 17.3). Het inloggen lukte bij mij wel nog zonder aanpassingen te doen.

    Reageren
  2. Luc

    Dank je wel voor deze tip, ik zal wel even wachten op FF58 en ondertussen mijn Token kaart gebruiken.

    Reageren
  3. Gert

    Op mijn PC ook geen problemen met de eID in Firefox 57 (Chalet OS). Op mijn laptop met Linux Mint 17.1 moest ik enkel de eID add-on even herinstalleren.

    Reageren
  4. Benny

    Raar, gisteren ging het nog wel en nu lukt het inderdaad niet meer….

    Reageren
  5. Kevin

    Firefox 57 en EID gebruiken ZONDER DOWNGRADEN: HET KAN!
    ——————————————————————————————

    Kijk op deze pagina:
    https://eid.belgium.be/en/log#7499

    Vriendelijke groeten
    Kevin

    Noot: als je een upgrade gedaan hebt (versie 56 naar versie 57) zou alles moeten blijven werken en zijn wijzigingen niet nodig…)
    Enkel ‘nieuwe installaties’ kennen dit probleem blijkbaar.

    Reageren
    1. georges

      Dit werk bij niet in Linux, enkel bij Windows werkt dat. De oplossing van eidbelgium staat trouwens onder de rubriek
      “On Windows”

      Reageren
      1. georges

        Er is een nieuwe update van de add-on eiD België 1.0.26 (versie 30/11/2017). Heb deze geïnstalleerd en dat werkt in Linux mint. Probleem opgelost.

        Reageren

Geef een reactie

%d bloggers liken dit: